PHP2Shell and Node2Shell are separate security problems patched on 21 October 2026. PHP2Shell covers two remote code execution flaws in PHP; Node2Shell, also called HTTP2Shell, is a memory-corruption flaw in the Brotli decoder used by Node.js and other software.12 Both are confirmed as exploited. Update the affected runtime, restart it, then check whether anything happened before the patch.
Last verified: 4 November 2026
Am I affected? PHP2Shell — CVE-2026-109618 and CVE-2026-109619: Both score 9.2 under CVSS 4.0. Fixed in PHP 8.5.12, 8.4.27, 8.3.36 and 8.2.35. PHP 8.1 and older have no new official release; the PHP team provided source backports for 7.4, 8.0 and 8.1. CISA added both CVEs on 26 October, with a federal deadline of 29 October.13 Node2Shell / HTTP2Shell — CVE-2026-111497: A Brotli decoder out-of-bounds write, also rated 9.2 under CVSS 4.0. Official Node.js fixes are 22.23.4, 24.22.1 and 26.12.1. Node.js 18, 20 and 25 received no upstream fix in that release. Python, .NET, Bun and other products need their own fixes. CISA added it on 27 October, with a federal deadline of 10 November.234 A third PHP flaw — CVE-2026-115560: Separate from PHP2Shell. PHP's 23 October advisory describes an unusual combination of session serialization settings and application code. No patch was announced as of this verification; PHP recommends session.upload_progress.enabled=0 until the fix ships.1