PHP fixed the two PHP2Shell flaws on 21 October 2026.1 The managed and shared hosts I checked reported fixed builds by 22 October, and VPS and dedicated customers were told to patch themselves.234 If you run a VPS or dedicated server, check which build you have, and if it isn't a confirmed fixed one, patch and restart today. If you're on shared or managed hosting, get your host's patched build number in writing this week.
Confirmed vulnerable: PHP below 8.5.12, 8.4.27, 8.3.36 or 8.2.35 on a branch with no vendor backport, serving web requests, or any build your vendor lists as unfixed. Confirmed patched: your host or vendor documents that a build with fixes for both CVE-2026-109618 and CVE-2026-109619 is installed, and the PHP workers restarted. Unverified: everything else, including VPS and shared plans where nobody has checked yet. Managing PHP yourself makes the patch your job. It doesn't make you vulnerable. None of these states covers CVE-2026-115560, a third flaw the 21 October releases do not fix. Status as of 4 November 2026, from provider notices dated 20 to 27 October.
The complete PHP2Shell guide covers both flaws in full. This article covers one question: did your host do the work, and how do you check?